Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Clutch problems

  1. #11
    Senior Member MightyMirageMpg's Avatar
    Join Date
    Apr 2016
    Location
    wi
    Country
    United States
    Posts
    692
    Thanks
    386
    Thanked 261 Times in 165 Posts
    There is no adjustment. I would suspect the cables were installed backwards. It looks goofy but they need to cross over eachother to be on the correct pegs.

    Hope that makes sense



  2. The Following User Says Thank You to MightyMirageMpg For This Useful Post:

    MetroMPG (09-06-2016)

  3. #12
    Junior Member
    Join Date
    Aug 2016
    Location
    OK
    Country
    United States
    Posts
    7
    Garage empty: add car
    Thanks
    0
    Thanked 1 Time in 1 Post
    It does make sense. I will check it. Thanks.

  4. #13
    Moderator Eggman's Avatar
    Join Date
    Sep 2015
    Location
    Ohio ☼
    Country
    United States
    Posts
    3,790
    Thanks
    2,508
    Thanked 947 Times in 707 Posts
    Quote Originally Posted by Dennisrshelby View Post
    It does make sense. I will check it. Thanks.
    Hey Dennisrshelby what did you find? Was it a crossed cable problem or something else?


    Welcome to MirageForum.com
    Forums work best when information is shared.
    And don't forget pictures.
    Mitsubishi Is Not Dead Yet

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 manual: 49.6 mpg (US) ... 21.1 km/L ... 4.7 L/100 km ... 59.6 mpg (Imp)


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •