Results 1 to 8 of 8

Thread: Rpm drop while accelerating from a stop

  1. #1
    Junior Member
    Join Date
    Sep 2017
    Location
    Pakistan
    Country
    Pakistan
    Posts
    3
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Rpm drop while accelerating from a stop

    Hey guys. I have a mirage 2013, imported from japan and its 1.0 liter. Clock is 42k km. Problem is that when i take a start, rpm goes to 2k and then drops to 1200, then very slowly it climbs back up. If i push it, it doesnt wanna go. Fuel economy has droped to half. Maf, tps, o2 sensor data is all fine. Ltft and stft are both +- 4.5 max. Replaced plugs and cvtf. Cleaned throttle body, got cat cleaned. Nk difference at all. It feels like it doesnt wana move. Started a month ago. No error code. Need help. Dont know what to do anymore.



  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    447
    Garage empty: add car
    Thanks
    122
    Thanked 270 Times in 152 Posts
    Does it make a difference if you put it in B' instead of D'? Do your brake lights work properly, possibly the brake switch is defective. The computer cuts throttle if you try hitting the brakes and gas at the same time. At least it did for me the one time I tried it. Do you have any aftermarket bulbs installed, they can cause weird problems sometimes I've read. Maybe pull the oil pan off the cvt and take a look for anything abnormal though It shouldn't have problems with that so soon.
    Didn't you already ask this under a different name? http://mirageforum.com/forum/showthr...ght-Hand-Drive or are there 2 cars with similar issues in Pakistan?

  3. The Following 3 Users Say Thank You to Fummins For This Useful Post:

    Alex1a1f (09-22-2017),Eggman (09-21-2017),Top_Fuel (09-22-2017)

  4. #3
    Junior Member
    Join Date
    Sep 2017
    Location
    Pakistan
    Country
    Pakistan
    Posts
    3
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts
    First thing, its not the same car. Good news is that i will now try this narrowing with tape thing. I forgot to mention that i did open the cvt pan and cleaned the filter before filling with new cvtf. No sir, nothing is after market. Completely stock. Brake lights work fine. Thanks for ur feedback.

  5. #4
    Junior Member
    Join Date
    Sep 2017
    Location
    Pakistan
    Country
    Pakistan
    Posts
    3
    Garage empty: add car
    Thanks
    0
    Thanked 0 Times in 0 Posts
    tried the narrowing thing but it made the problem worst. took it off. car feels like it's pulling some weight till 2000 rpm and after that suddenly it becomes ok but once i let go off the accelerator and then press it again, it does the same thing again i.e goes to 2000 and then drops back to 1400.

  6. #5
    Moderator Eggman's Avatar
    Join Date
    Sep 2015
    Location
    Ohio ☼
    Country
    United States
    Posts
    3,235
    Thanks
    2,165
    Thanked 780 Times in 582 Posts
    I have a Mirage with a manual transmission so I have no experience with the CVT. I understand it is programmed to try to keep engine RPMs low for fuel economy. Your case sounds like it's trying too hard?

    I wonder if one of your vehicle's sensors is reporting false information. Are you are able to monitor any of the on-board diagnostics, whether on your own or through a mechanic's garage?


    Quote Originally Posted by zeeshan View Post
    tried the narrowing thing but it made the problem worst. took it off. car feels like it's pulling some weight till 2000 rpm and after that suddenly it becomes ok but once i let go off the accelerator and then press it again, it does the same thing again i.e goes to 2000 and then drops back to 1400.
    The Jatco CVT used in this generation Mirage has a dual-range gear. Your description sounds like it is shifting into high range, which would be expected.


    Does your Mirage have stability control? What happens if this is turned off?
    Last edited by Eggman; 09-22-2017 at 09:52 AM.

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 manual: 49.8 mpg (US) ... 21.2 km/L ... 4.7 L/100 km ... 59.7 mpg (Imp)


  7. #6
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    447
    Garage empty: add car
    Thanks
    122
    Thanked 270 Times in 152 Posts
    Does it rev up normally in park/neutral? Does it have an eco light or similar that comes on when the rpms drop? How did you check your data for the sensors? Multimeter or scan tool?

  8. #7
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    447
    Garage empty: add car
    Thanks
    122
    Thanked 270 Times in 152 Posts
    I think I remember reading about someone having a problem with the sending unit. I can't recall if it was leaking fuel or loose plug, it's easy to see though if you lift the rear seat bottom and remove the small plate under it. You should be able to tell if you have a leak there pretty quick. Have you checked your fuel pressure?

  9. #8
    Senior Member MightyMirageMpg's Avatar
    Join Date
    Apr 2016
    Location
    wi
    Country
    United States
    Posts
    608
    Thanks
    343
    Thanked 223 Times in 141 Posts
    Quote Originally Posted by zeeshan View Post
    then very slowly it climbs back up. If i push it, it doesnt wanna go.e.
    What do you mean by it doesn't want to go.

    It revs but doesn't accelerate or it chokes and studders



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •