Results 1 to 1 of 1

Thread: Odd behavior today with touchscreen head unit.

  1. #1
    Senior Member IchabodCrane's Avatar
    Join Date
    Apr 2014
    Thunder Bay, ON. CA
    Thanked 292 Times in 179 Posts

    Odd behavior today with touchscreen head unit.

    The weirdness is strong with this one.
    Driving home after work today my head unit dropped Bluetooth connection with my HTC 10 while playing music and refused to reconnect.
    I pulled over, parked and used phone settings menu to delete all paired phones and tried re-pairing my phone.
    No go. I perused the menus and found unit info screen which also has factory reset folder and update software folder. Since I have no software to plug in I tried the factory reset. The unit proceeded to shut down and reboot to "factory settings". When done I was able to pair my phone and it's back to business as usual.
    In the brief review of the loaner '18 GT I drove I said it looked like updates had been done since my '17 was built as there were features and menu options my car doesn't have... Well guess what? Now I have them. Whaaaat?
    My head unit now has the feature of a banner at top of home screen showing what's playing through Bluetooth so I can see it without being on the media screen.
    Before today my head unit automatically downloaded contacts at Bluetooth startup. Now it does same but there is also a download contacts "button" previously missing.
    I did not think ahead to record the software version # b4 and after reset so I'm not sure if it reverted or updated.
    I believe my dealer had done at least one update to the head unit but I need to verify that yet.
    Back story..
    For most of my time with this car my HTC 10 and Google Play has worked very well with this head unit. As long as my phone and bluetooth were on the head unit would start the app, access the Playlist and start playing at last song all on it's own even with phone screen off and locked.
    In recent past though this functionality went south. I was having to turn on Bluetooth, connect, open "Play" app and hit play on my phone b4 the head unit would make a sound. Sometimes no sound was produced until I also pressed up volume button on phone as well.
    I have been dealing with Google about recent updates to their "play" music app which I thought had caused the reduced functionality I was seeing.
    After today's reset my head unit started the whole process on it's own again just like b4. I'm thinking now that it was the Mitsu update that killed the seamless functionality.
    If so... Why? Safety issues? A glitch?

    Last edited by IchabodCrane; 01-05-2018 at 02:56 AM.
    Will weld for beer.


        click to view fuel log View my fuel log 2014 Mirage SE 1.2 automatic: 45.3 mpg (US) ... 19.3 km/L ... 5.2 L/100 km ... 54.5 mpg (Imp)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts