Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Brake warning light

  1. #1
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts

    Brake warning light

    I've got a 17' that the brake warning "!" symbol is lit up. It has brake fluid and the e-brake is fully released. Has anyone else ran into this. All the brake lights work properly. I don't think my scanner can read anything other than basic engine lights on this thing.



  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts
    So far I unplugged the ebrake switch, and the fluid level switch on the master cylinder. Light still comes on, but not until the car is running for about 20 seconds, after doing a systems check I assume as the low washer light doesn't come on until about 3-5 seconds after car is started.

  3. #3
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts
    Off to the stealership it goes. I'm thinking a wiring or module problem around the lh footrest. I started doing the wiggle test in that area and the brake light flickered a bit. It still has under 100000kms so someone else can deal with it. The low washer fluid light stays on after I filled it up as well, I wonder if the 2 problems are related.

  4. #4
    Moderator Eggman's Avatar
    Join Date
    Sep 2015
    Location
    Cleveland, Ohio ☼
    Country
    United States
    Posts
    4,559
    Thanks
    2,705
    Thanked 1,161 Times in 863 Posts
    Hey Fummins the service manual says the brake warning light is used as a warning light for parking brake, brake fluid level, and EBD control. Seems you covered the first two, have you checked your EBD?

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 manual: 50.1 mpg (US) ... 21.3 km/L ... 4.7 L/100 km ... 60.2 mpg (Imp)


  5. #5
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts
    I assume that is part of the abs. I stopped trying and just took it in. The dealer is close by and were able to get it in the shop today,
    I'm not in a panic to get this one back on the road today so might as well get it fixed for free especially since it doesn't seem to be a quick fix. Still haven't heard from them but I know they have it in the shop. It's nice having gps tracking.

  6. #6
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts
    I just got a call. They think it's the cluster and ordered one in. They didn't sound overly confident that's gonna fix it. Just said they'll change that first then try something else if that doesn't fix it.
    Last edited by Fummins; 02-22-2018 at 09:46 PM. Reason: I'm less grouchy now

  7. #7
    Moderator Eggman's Avatar
    Join Date
    Sep 2015
    Location
    Cleveland, Ohio ☼
    Country
    United States
    Posts
    4,559
    Thanks
    2,705
    Thanked 1,161 Times in 863 Posts
    Well, they've certainly gotten enough business from your boss.

    Sounds as if they don't know how to properly diagnose this. There must be a diagnostic code in there somewhere.

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 manual: 50.1 mpg (US) ... 21.3 km/L ... 4.7 L/100 km ... 60.2 mpg (Imp)


  8. #8
    Administrator MetroMPG's Avatar
    Join Date
    Jan 2013
    Location
    1000 Islands, Ontario
    Country
    Canada
    Posts
    6,813
    Thanks
    2,328
    Thanked 1,900 Times in 1,165 Posts
    You shoulda stuck the worn out starter in it too, since you were sending it in.

        __________________________________________

        click to view fuel log View my fuel log 2014 Mirage base ES 1.2 manual: 54.0 mpg (US) ... 23.0 km/L ... 4.4 L/100 km ... 64.9 mpg (Imp)


  9. The Following User Says Thank You to MetroMPG For This Useful Post:

    Fummins (02-23-2018)

  10. #9
    Senior Member
    Join Date
    Mar 2017
    Location
    Minnesota
    Country
    United States
    Posts
    532
    Thanks
    188
    Thanked 148 Times in 102 Posts
    The whole instrument cluster?

    I know I speak for everyone but I really appreciate your posts as it helps us for possible future repairs when they might come up. You having a fleet and all. Plus fleet cars are under much more wear and tear.

  11. #10
    Senior Member
    Join Date
    Oct 2016
    Location
    ab
    Country
    Canada
    Posts
    1,052
    Garage empty: add car
    Thanks
    420
    Thanked 607 Times in 344 Posts
    If there was an abs light I'm sure there'd be a code stored. Can't be certain about the brake light and I doubt it with the washer fluid. They tested the washer fluid level sensor and it was fine. The washer light comes on everytime a few seconds after turning the key on. The brake light sometimes comes on instantly and stays on and sometimes waits 20-30 seconds and when it comes on it flickers on and off like it has a bad connection then stays on constantly. It's totally possible it was just a coincidence it was flickering when I was wiggling wires. It's weird.

    We were joking about changing the starter while it was running then drive it there for the airbag recall lol. They might wonder why all the bolts look like they've been removed.

    And yeah, from my understanding they're wanting to replace the entire cluster.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •