Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: CVT Transmission is jerky/clunky (please help!)

  1. #21
    Senior Member
    Join Date
    Jan 2019
    Location
    IL
    Country
    United States
    Posts
    624
    Thanks
    0
    Thanked 146 Times in 119 Posts
    When you drove a stick Mirage as a loaner, was it a gray one that was at Mad City Mitsubishi? If so, that was my old car. I bought it new and traded it back in for an Outlander Sport. Someone smoked in it and trashed the heck out of it... it was super nice when I traded it in...


    -Karl B. 2015 Mirage DE 5 speed. Plenty of other cars as well.

  2. #22
    Member
    Join Date
    Jul 2020
    Location
    WI
    Country
    United States
    Posts
    36
    Thanks
    0
    Thanked 5 Times in 4 Posts
    Quote Originally Posted by Dodge Aries K View Post
    When you drove a stick Mirage as a loaner, was it a gray one that was at Mad City Mitsubishi? If so, that was my old car. I bought it new and traded it back in for an Outlander Sport. Someone smoked in it and trashed the heck out of it... it was super nice when I traded it in...
    LMAO. Wow, what a small world we live in. I can confirm it still smells like smoke.

  3. #23
    Senior Member
    Join Date
    Jan 2019
    Location
    IL
    Country
    United States
    Posts
    624
    Thanks
    0
    Thanked 146 Times in 119 Posts
    Yeah when I rode in it recently I was shocked how destroyed it was. Someone crashed it too... The front end is all bent down. Such a waste.
    -Karl B. 2015 Mirage DE 5 speed. Plenty of other cars as well.

  4. #24
    Member
    Join Date
    Jul 2020
    Location
    WI
    Country
    United States
    Posts
    36
    Thanks
    0
    Thanked 5 Times in 4 Posts
    Quote Originally Posted by Dodge Aries K View Post
    Yeah when I rode in it recently I was shocked how destroyed it was. Someone crashed it too... The front end is all bent down. Such a waste.
    Do you use that dealership often for service? I'm interested to hear what your experience with them has been like. I haven't made any conclusions yet.

  5. #25
    Senior Member
    Join Date
    Jan 2019
    Location
    IL
    Country
    United States
    Posts
    624
    Thanks
    0
    Thanked 146 Times in 119 Posts
    Service was decent. Sales is garbage. But the whole place got bought out by Kunes Country so who knows what will happen now.
    -Karl B. 2015 Mirage DE 5 speed. Plenty of other cars as well.

  6. #26
    Member
    Join Date
    Jul 2020
    Location
    WI
    Country
    United States
    Posts
    36
    Thanks
    0
    Thanked 5 Times in 4 Posts
    Great news! I am no longer experiencing the severe shift shock that was happening before. There is still very minor shift shock but I believe that is just this CVT transmission doing its thing. I did still have the issue with needing to go halfway to Park before Reverse was being engaged. But that was just fixed this morning by replacing a broken bushing inside the shifter. Again, not sure why this wasn't noticed on the test drive (second time now) but it's fixed and for free, so I'm a happy camper. The only other issue I have had, has happen twice now, randomly when driving, the ABS and both traction controls lights on the dash illuminate. Nothing noticeable happens with the driving. Both times I pulled over, turned the car off and on, and it went away. The dealer told me that if it happens again to not shut the car off and bring it right to them to check codes (they couldn't find any codes this morning). Has anyone else had this issue?

  7. The Following User Says Thank You to WI_Mirage For This Useful Post:

    MetroMPG (07-24-2020)

  8. #27
    Moderator inuvik's Avatar
    Join Date
    May 2015
    Location
    Coos Bay, OR
    Country
    United States
    Posts
    2,978
    Thanks
    2,460
    Thanked 1,107 Times in 805 Posts
    Quote Originally Posted by WI_Mirage View Post
    Great news! I am no longer experiencing the severe shift shock that was happening before. There is still very minor shift shock but I believe that is just this CVT transmission doing its thing. I did still have the issue with needing to go halfway to Park before Reverse was being engaged. But that was just fixed this morning by replacing a broken bushing inside the shifter. Again, not sure why this wasn't noticed on the test drive (second time now) but it's fixed and for free, so I'm a happy camper. The only other issue I have had, has happen twice now, randomly when driving, the ABS and both traction controls lights on the dash illuminate. Nothing noticeable happens with the driving. Both times I pulled over, turned the car off and on, and it went away. The dealer told me that if it happens again to not shut the car off and bring it right to them to check codes (they couldn't find any codes this morning). Has anyone else had this issue?
    I had this happen a couple of times and my ETACS control unit was replaced under warranty early on and I never had another issue. In fact has been my only issue in the 5+ years I've owned it.

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 automatic: 40.4 mpg (US) ... 17.2 km/L ... 5.8 L/100 km ... 48.5 mpg (Imp)


  9. #28
    Member
    Join Date
    Jul 2020
    Location
    WI
    Country
    United States
    Posts
    36
    Thanks
    0
    Thanked 5 Times in 4 Posts
    Quote Originally Posted by inuvik View Post
    I had this happen a couple of times and my ETACS control unit was replaced under warranty early on and I never had another issue. In fact has been my only issue in the 5+ years I've owned it.
    I think I have a lemon, and the previous owners abused this lemon badly. Every time something is fixed another thing breaks. It's non-stop in this car. I will definitely bring the car in if it happens again, because they might replace the ETACS (if that's the issues) under warranty because the tranny was under warranty, and this did not happen ever before the tranny replacement.

  10. #29
    Senior Member Top_Fuel's Avatar
    Join Date
    Feb 2016
    Location
    Ohio
    Country
    United States
    Posts
    2,615
    Thanks
    1,576
    Thanked 1,592 Times in 921 Posts
    Quote Originally Posted by WI_Mirage View Post
    ...randomly when driving, the ABS and both traction controls lights on the dash illuminate.
    When it happens...write it down and keep a log...maybe with a short description of any odd conditions when it happens (cruising along normally...hit a bump...only happens when I turn on the radio, only happens when it rains, etc). This will hopefully let the dealer know that you aren't a typical customer complaining about something...but you can't provide any useful details.

    With any luck it will happen often enough that the dealer can duplicate the issue.

        __________________________________________

        click to view fuel log View my fuel log 2015 Mirage ES 1.2 manual: 52.0 mpg (US) ... 22.1 km/L ... 4.5 L/100 km ... 62.4 mpg (Imp)


  11. The Following User Says Thank You to Top_Fuel For This Useful Post:

    Fummins (07-15-2020)

  12. #30
    Cornwallis Fummins's Avatar
    Join Date
    Oct 2016
    Location
    Pyongyang
    Country
    North Korea
    Posts
    4,331
    Thanks
    1,693
    Thanked 1,978 Times in 1,331 Posts
    Quote Originally Posted by WI_Mirage View Post
    The only other issue I have had, has happen twice now, randomly when driving, the ABS and both traction controls lights on the dash illuminate. Has anyone else had this issue?
    Do you have anything plugged into your obdII port? If so unplug it.

    Are all your brake lights working? Using led bulbs back there? If so take them out and put normy ones back in.

    If both of those check out ok then hopefully your dealer is able to pull some codes and go from there. Not much sense guessing, it literally could be anything from a bad wheel bearing, abs wires broken, brake switch, damaged/corroded connectors or wiring, something not plugged in properly, worn rear wiper blade.....


    My mom says I'm cool

        __________________________________________

        click to view fuel log View my fuel log 2014 Mirage SE wussie cvt edition. 1.2 automatic: 37.4 mpg (US) ... 15.9 km/L ... 6.3 L/100 km ... 44.9 mpg (Imp)


  13. The Following User Says Thank You to Fummins For This Useful Post:

    Top_Fuel (07-15-2020)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •